Looking for a Professional INFO-GRAPHICS DESIGNER ? Order Now $5

Basic EPON OLT CLI Configure | CDATA | ECOM

Learn, How to configure CDATA / ECOM - EPON OLT CLI configuration

Working Device Model:

EPON 4/8/16 PON Ports. Hardware versions v1.0. Version: B0

N.B.Ensure 1G to 1G SFP or 10G to 10G SFP Connection

  1. LOGIN Procedure:

  2. Ensure the privilege (root/admin/guest) level

    Cofigure the OLT device you'll need to access the device properly. There are several methods to login OLT device like Use console port, MGMT Port, Type-C Port (if available). And access remotely within same network.

    Console Port:

    N.B.Maintain Console cable with Console Converter


    Step 1: Use DB9 USB converter for Console
    Step 2: Connect with OLT Console port to PC USB
    Step 3: Download and install terminal software for gain access
    Step 4: Find the COM port no and use 9600 data rate for EPON

    MGMT Port:

    N.B.Any UPT cable can be use fot local access of OLT


    Step 1: Connect UTP cable with OLT MGMT to PC LAN
    Step 2: Set same series of OLT IP on the PC Network Adapter
    Step 3: Browse with the OLT IP into PC browser





  3. General Identefication

  4. Keep update your Firmware version

    To Administrate any OLT you must ensure it has latest firmware version. Maintain proper device identification name/no to identify among many devices. Also, it is advised keep the temperature in good range for longevity of the device

    Device Name

    N.B.To Identify by Name you can change Device name with this command


    OLT(config)#
    OLT(config)# sysname ECOM-EPON-OLT
    ECOM-EPON-OLT(config)#

    Version Info

    N.B.Check OLT firmware version info


    OLT(config)#
    OLT(config)# show version
    ECOM-EPON-OLT(config)#

    Device Info

    N.B.Check device info like Device MAC, Vendor name, Model e.t.c


    OLT(config)#
    OLT(config)# show device
    ECOM-EPON-OLT(config)#





  5. VLAN Configure

  6. Port mode is important for VLAN

    Virtual LAN (VLAN) helps reduce brodcast and collison domain. Also it prevent LOOP issue. VLAN actually divide one LAN into many LAN within a port. Ensure how you want to serve with VLAN in your network. According to that service plan ensure port mode.

    VLAN Create

    N.B.Create One or Multiple VLAN at a time

    ECOM-EPON-OLT(config)# vlan 46
    ECOM-EPON-OLT(config)# vlan 47,48
    ECOM-EPON-OLT(config)# vlan 50-100
    ECOM-EPON-OLT(config)# vlan 11-13,26,28,30-45

    VLAN Delete

    N.B.Delete One or Multiple VLAN at a time

    ECOM-EPON-OLT(config)# no vlan 46
    ECOM-EPON-OLT(config)# no vlan 47,48
    ECOM-EPON-OLT(config)# no vlan 50-100
    ECOM-EPON-OLT(config)# no vlan 11-13,26,28,30-45

    PON VLAN Assign

    N.B.Assign VLAN on PON Ports

    ECOM(config)#
    ECOM(config)# interface epon 0/0
    ECOM(config-interface-epon-0/0)#vlan mode 1 access
    ECOM(config-interface-epon-0/0)#vlan native-vlan 1 11
    ECOM(config)#
    ECOM(config-interface-epon-0/0)#vlan mode 2 trunk
    ECOM(config-interface-epon-0/0)#vlan trunk 2 22,24-28
    ECOM(config)#
    ECOM(config-interface-epon-0/0)#vlan mode 3 hybrid
    ECOM(config-interface-epon-0/0)#vlan hybrid 3 tagged 33
    ECOM(config-interface-epon-0/0)#vlan hybrid 3 untagged 34
    ECOM(config-interface-epon-0/0)#vlan native-vlan 3 35
    ECOM(config-interface-epon-0/0)# exit
    ECOM(config)#

    ONU VLAN

    N.B.VLAN tagging (one or many) on specific ONU

    #01 Tag Single VLAN on specific ONU

    ECOM(config)#
    ECOM(config)# interface epon 0/0
    ECOM(config-interface-epon-0/0)# ont port native-vlan 1 1 eth 1 vlan 46
    ECOM(config-interface-epon-0/0)# exit
    ECOM(config)#

    #02 Tag Multiple VLAN on specific ONU

    ECOM(config)#
    ECOM(config)# interface epon 0/0
    ECOM(config-interface-epon-0/0)# ont port vlan 1 1 eth 1 translation 110 user-vlan 110
    ECOM(config-interface-epon-0/0)# ont port vlan 1 1 eth 1 translation 111 user-vlan 111
    ECOM(config-interface-epon-0/0)# ont port vlan 1 1 eth 1 translation 112 user-vlan 112
    ECOM(config-interface-epon-0/0)# ont port vlan 1 1 eth 1 translation 113 user-vlan 113
    ECOM(config-interface-epon-0/0)# exit

    GE UP-Link Port VLAN

    N.B.UP-Link VLAN Assign on GE(1G) or XGE(10G) Ports

    ECOM(config)#
    ECOM(config)#interface ge 0/0
    ECOM(config-interface-ge-0/0)#vlan mode 1 access
    ECOM(config-interface-ge-0/0)#vlan native-vlan 1 11
    ECOM(config)#
    ECOM(config-interface-ge-0/0)#vlan mode 2 trunk
    ECOM(config-interface-ge-0/0)#vlan trunk 2 22-24,28
    ECOM(config)#
    ECOM(config-interface-ge-0/0)#vlan mode 3 hybrid
    ECOM(config-interface-ge-0/0)#vlan hybrid 3 tagged 33-35
    ECOM(config-interface-ge-0/0)#vlan hybrid 3 untagged 36-38
    ECOM(config-interface-ge-0/0)#vlan native-vlan 3 39
    ECOM(config-interface-ge-0/0)#exit

    LACP VLAN Assign

    N.B.Assign VLAN on Link Aggregation Control Protocol (LACP) Port

    ECOM(config)#
    ECOM(config)#interface ge 0/0
    ECOM(config-interface-ge-0/0)#vlan mode 1 access
    ECOM(config-interface-ge-0/0)#vlan native-vlan 1 11
    ECOM(config)#
    ECOM(config-interface-ge-0/0)#vlan mode 2 trunk
    ECOM(config-interface-ge-0/0)#vlan trunk 2 22-24,28
    ECOM(config)#
    ECOM(config-interface-ge-0/0)#vlan mode 3 hybrid
    ECOM(config-interface-ge-0/0)#vlan hybrid 3 tagged 33-35
    ECOM(config-interface-ge-0/0)#vlan hybrid 3 untagged 36-38
    ECOM(config-interface-ge-0/0)#vlan native-vlan 3 39
    ECOM(config-interface-ge-0/0)#exit





  7. PORT Configure

  8. Access for one VLAN, TRUNK/Hybrid for many

    Here, Port mode will enable VLAN passing function. Access/PVID/Native for one VLAN. Trunk and hybrid

    PON Mode change

    N.B.Change PON Port mode into access/trunk/hybrid mode.
    -Access mode allows single VLAN only
    -Trunk mode allows Multiple VLAN
    -Hybrid mode is the combination of Access and Trunk Both


    ECOM(config)# interface epon 0/0
    ECOM(config-interface-epon-0/0)# vlan mode 1 access
    ECOM(config-interface-epon-0/0)# vlan mode 2 trunk
    ECOM(config-interface-epon-0/0)# vlan mode 3 hybrid
    ECOM(config)#

    GE Mode change

    N.B.Configure GE (1G) UP-link port mode


    ECOM(config)# interface ge 0/0
    ECOM(config-interface-ge-0/0)#vlan mode 1 access
    ECOM(config-interface-ge-0/0)# vlan mode 2 trunk
    ECOM(config-interface-ge-0/0)#vlan mode 3 hybrid

    XGE Mode change

    N.B.Configure XGE (10G) UP-Link port mode

    ECOM(config)# interface xge 0/0
    ECOM(config-interface-xge-0/0)#vlan mode 1 access
    ECOM(config-interface-xge-0/0)# vlan mode 2 trunk
    ECOM(config-interface-xge-0/0)# vlan mode 3 hybrid

    LACP Mode change

    N.B.Configure LACP port mode

    ECOM-EPON-OLT(config)# DEMO





  9. Remote Management IP Configure

  10. Assign IP

    N.B.Configure the Default VLAN IP for remote access


    Step-#01 Assign IP
    ECOM-EPON-OLT(config)#
    ECOM-EPON-OLT(config)#
    interface vlanif 1
    ECOM-EPON-OLT(config-interface-vlanif-1)#
    ip address 192.168.89.22 255.255.255.0
    ECOM-EPON-OLT(config-interface-vlanif-1)#
    exit
    ECOM-EPON-OLT(config)#


    Step-#02 Route The IP
    ECOM-EPON-OLT(config)#
    ECOM-EPON-OLT(config)#
    ip route 0.0.0.0/0 192.168.89.1
    ECOM-EPON-OLT(config)#

    Assign IP on VLAN

    N.B.Configure GE (1G) UP-link port mode


    ECOM-EPON-OLT(config)#
    ECOM-EPON-OLT(config)#
    interface vlanif 46
    ECOM-EPON-OLT(config-interface-vlanif-46)#
    ip address 192.168.89.22 255.255.255.0
    ECOM-EPON-OLT(config-interface-vlanif-46)#
    exit
    ECOM-EPON-OLT(config)#

    MGMT IP Change

    N.B. Coming Soon


    ECOM(config)# DEMO





  11. Configure LOOP Protection

  12. Global Loop

    N.B.Activate Global LOOP Protection for whole OLT. For this configuration, If LOOP raised then whole OLT will down


    ECOM(config)#
    ECOM(config)# loopback-detection enable
    ECOM(config)#

    PON Port Loop

    N.B.Activate LOOP Protection on every PON Port individually.. For this configuration, If LOOP raised into any PON. Then that will down


    ECOM(config)# interface epon 0/0
    ECOM(config-interface-epon-0/0)# loopback-detection 1-8 enable
    ECOM(config-interface-epon-0/0)# exit

    UPLink PORT Loop

    N.B.Activate LOOP Protection on the GE (1G) and XGE (10G). For this configuration, If LOOP raised then that UP-Link will down


    ECOM(config)#
    ECOM(config)# interface ge 0/0
    ECOM(config-interface-ge-0/0)# loopback-detection 1-8 enable
    ECOM(config-interface-ge-0/0)# exit
    ECOM(config)#
    ECOM(config)# interface xge 0/0
    ECOM(config-interface-xge-0/0)# loopback-detection 1-2 enable
    ECOM(config-interface-xge-0/0)#exit

    ONU Loop

    N.B.Activate LOOP protection on all ONU. Remember, Every time new ONU register you have to run this command everytime for that newly registered ONU


    ECOM(config)#
    ECOM(config)# interface epon 0/0
    ECOM(config-interface-epon-0/0)# ont ring check 1 all enable
    ECOM(config-interface-epon-0/0)# ont ring check 2 all enable
    ECOM(config-interface-epon-0/0)# ont ring check 3 all enable
    ECOM(config-interface-epon-0/0)# exit
    ECOM(config)#

    ONU Blacklist

    N.B. Whenever LOOP raise try to clear the loop physically. If not possible block the ONU


    Step 1: Add the ONU to Blacklist

    ECOM(config)#
    ECOM(config)# interface epon 0/0
    ECOM(config-interface-epon-0/0)# ont black-list add 4 00:00:00:00:00:00
    ECOM(config-interface-epon-0/0)# exit
    ECOM(config)#


    Step 2: Delete the ONU from Blacklist

    ECOM(config)#
    ECOM(config)# interface epon 0/0
    ECOM(config-interface-epon-0/0)# ont black-list del 4 00:00:00:00:00:00
    ECOM(config-interface-epon-0/0)# exit
    ECOM(config)#





  13. Check Minor Information

  14. ONU Info

    ONU Info

    N.B. With this command you will find how many ONU has been registered into a specific PON port. Also, with this CLI command you can check How many ONU online and how many ONU are offline

    ECOM-EPON-OLT(config)#
    ECOM-EPON-OLT(config)# show ont info 0/0 1 all
    ECOM-EPON-OLT(config)# show ont info 0/0 2 all
    ECOM-EPON-OLT(config)# show ont info 0/0 3 all
    ECOM-EPON-OLT(config)# show ont info 0/0 4 all


    N.B.With this command you can check UP Time, Model, Approximate distance and Type of ONU

    ECOM-EPON-OLT(config)#
    ECOM-EPON-OLT(config)# show ont basic-info 0/0 1 all
    ECOM-EPON-OLT(config)# show ont basic-info 0/0 2 all
    ECOM-EPON-OLT(config)# show ont basic-info 0/0 3 all
    ECOM-EPON-OLT(config)# show ont basic-info 0/0 4 all
    ECOM-EPON-OLT(config)#

    ONU Optical Tx/Rx Info

    N.B.Here you can find ONU Rx, Tx, Bias current, Voltage and Temperature

    ECOM-EPON-OLT(config)#
    ECOM-EPON-OLT(config)# interface epon 0/0
    ECOM-EPON-OLT(config)# show ont optical-info 1 all
    ECOM-EPON-OLT(config)# show ont optical-info 2 all
    ECOM-EPON-OLT(config)# show ont optical-info 3 all
    ECOM-EPON-OLT(config)# show ont optical-info 4 all
    ECOM-EPON-OLT(config)#

    Delete all offline ONU

    N.B.With this command all Offile ONU will delete at a time

    ECOM-EPON-OLT(config)#
    ECOM-EPON-OLT(config)# ont delete offline-list 1 all
    ECOM-EPON-OLT(config)# ont delete offline-list 2 all
    ECOM-EPON-OLT(config)# ont delete offline-list 3 all
    ECOM-EPON-OLT(config)# ont delete offline-list 4 all
    ECOM-EPON-OLT(config)#

    Delete all ONU (Online/Offline)

    N.B.With this command all (Offile + Online) ONU will delete at a time

    ECOM-EPON-OLT(config)#
    ECOM-EPON-OLT(config)# ont delete 1 all
    ECOM-EPON-OLT(config)# y
    ECOM-EPON-OLT(config)# ont delete 2 all
    ECOM-EPON-OLT(config)# y
    ECOM-EPON-OLT(config)# ont delete 3 all
    ECOM-EPON-OLT(config)# y
    ECOM-EPON-OLT(config)# ont delete 4 all
    ECOM-EPON-OLT(config)# y
    ECOM-EPON-OLT(config)#

    ONU User MAC

    N.B.Here you'll find the end user MAC address. It means The user who connected with ONU LAN, It's MAC address will show with this command. The MAC address could be any device like OLT, ONU, Switch, Server, PC, Router any L2/L3 devices


    ECOM-EPON-OLT(config)#
    ECOM-EPON-OLT(config)# show mac-address ont 0/0/1 18
    ECOM-EPON-OLT(config)#




  15. Check Other important Info

  16. Check FAN

    N.B.DEMO


    ECOM(config)#
    ECOM(config)# show fan
    ECOM(config)#

    Check CPU

    N.B.DEMO


    ECOM(config)#
    ECOM(config)# show cpu
    ECOM(config)#

    Check RAM

    N.B.DEMO


    ECOM(config)#
    ECOM(config)# show memory
    ECOM(config)#

    Check Temperature

    N.B.DEMO


    ECOM(config)#
    ECOM(config)# show temperature
    ECOM(config)#

    Check UPTIME

    N.B.DEMO


    ECOM(config)#
    ECOM(config)# show uptime
    ECOM(config)#

    Check Power Supply

    N.B.DEMO


    ECOM(config)#
    ECOM(config)# show power state
    ECOM(config)#

Post a Comment

Please do not enter any spam link...
© A Balancer. All rights reserved. Made by ABalancer